Start Updating moodle

Updating moodle

If you decide not to do this, make sure you have good backups.

Just make sure you check for available updates (via the button for it) at the Plugins check screen.

Please note that if you use My SQL you must upgrade the engine to Inno DB since it has become a requirement in Moodle 3.1. Note 1: The Assignment activity can now convert various office document formats to PDF to work with PDF annotations.

This is optional - but it requires "unoconv" to be installed and configured on the server. Note 2: You can only upgrade to Moodle 3.1 from Moodle 2.7 or later.

If upgrading from earlier versions, you must upgrade to 2.2 as a first step.

Note: You can only upgrade to Moodle 2.6 from Moodle 2.2 or later.

We advise that you test the upgrade first on a COPY of your production site, to make sure it works as you expect.

There are three areas that should be backed up before any upgrade: See Site backup for more specific information.

Hi, I am using bitnami moodle 3.1 Virtual Machines. Currently I want to upgrade to the developmnet version of Moodle 3.2. Could you please take a look at it and follow the steps described on it?